CVE-2023-25742

NameCVE-2023-25742
DescriptionWhen importing a SPKI RSA public key as ECDSA P-256, the key would be handled incorrectly causing the tab to crash. This vulnerability affects Firefox < 110, Thunderbird < 102.8, and Firefox ESR < 102.8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3319-1, DLA-3324-1, DSA-5350-1, DSA-5355-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid128.0-1fixed
firefox-esr (PTS)bullseye115.12.0esr-1~deb11u1fixed
bullseye (security)115.13.0esr-1~deb11u1fixed
bookworm115.12.0esr-1~deb12u1fixed
bookworm (security)115.13.0esr-1~deb12u1fixed
trixie115.12.0esr-1fixed
sid115.13.0esr-1fixed
thunderbird (PTS)bullseye (security), bullseye1:115.12.0-1~deb11u1fixed
bookworm, bookworm (security)1:115.12.0-1~deb12u1fixed
sid, trixie1:115.12.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)110.0-1
firefox-esrsourcebuster102.8.0esr-1~deb10u1DLA-3319-1
firefox-esrsourcebullseye102.8.0esr-1~deb11u1DSA-5350-1
firefox-esrsource(unstable)102.8.0esr-1
thunderbirdsourcebuster1:102.8.0-1~deb10u1DLA-3324-1
thunderbirdsourcebullseye1:102.8.0-1~deb11u1DSA-5355-1
thunderbirdsource(unstable)1:102.8.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2023-05/#CVE-2023-25742
https://www.mozilla.org/en-US/security/advisories/mfsa2023-06/#CVE-2023-25742
https://www.mozilla.org/en-US/security/advisories/mfsa2023-07/#CVE-2023-25742

Search for package or bug name: Reporting problems