CVE-2023-2609

NameCVE-2023-2609
DescriptionNULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.1531.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6vulnerable
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2vulnerable
sid, trixie2:9.1.0016-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:9.0.1658-1unimportant

Notes

https://huntr.dev/bounties/1679be5a-565f-4a44-a430-836412a0b622
https://github.com/vim/vim/commit/d1ae8366aff286d41e7f5bc513cc0a1af5130aad (v9.0.1531)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems