CVE-2023-26159

NameCVE-2023-26159
DescriptionVersions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site, potentially leading to information disclosure, phishing attacks, or other security breaches.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1059926

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-follow-redirects (PTS)buster1.2.4-1vulnerable
bullseye1.13.1-1+deb11u1vulnerable
bookworm1.15.2+~1.14.1-1vulnerable
trixie, sid1.15.3+~1.14.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-follow-redirectssource(unstable)(unfixed)1059926

Notes

[bookworm] - node-follow-redirects <no-dsa> (Minor issue)
[bullseye] - node-follow-redirects <no-dsa> (Minor issue)
[buster] - node-follow-redirects <no-dsa> (Minor issue)
https://security.snyk.io/vuln/SNYK-JS-FOLLOWREDIRECTS-6141137
https://github.com/follow-redirects/follow-redirects/issues/235
https://github.com/follow-redirects/follow-redirects/pull/236
https://github.com/follow-redirects/follow-redirects/commit/1cba8e85fa73f563a439fe460cf028688e4358df (v1.15.4)
https://github.com/follow-redirects/follow-redirects/commit/05629af696588b90d64e738bc2e809a97a5f92fc (v1.15.4)
https://github.com/follow-redirects/follow-redirects/commit/7a6567e16dfa9ad18a70bfe91784c28653fbf19d (v1.15.4)

Search for package or bug name: Reporting problems