CVE-2023-26253

NameCVE-2023-26253
DescriptionIn Gluster GlusterFS 11.0, there is an xlators/mount/fuse/src/fuse-bridge.c notify stack-based buffer over-read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1031731

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glusterfs (PTS)buster5.5-3vulnerable
bullseye9.2-1vulnerable
bookworm10.3-5fixed
sid, trixie11.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glusterfssource(unstable)10.3-51031731

Notes

[bullseye] - glusterfs <no-dsa> (Minor issue)
[buster] - glusterfs <no-dsa> (Minor issue)
https://github.com/gluster/glusterfs/issues/3954

Search for package or bug name: Reporting problems