CVE-2023-26590

NameCVE-2023-26590
DescriptionA floating point exception vulnerability was found in sox, in the lsx_aiffstartwrite function at sox/src/aiff.c:622:58. This flaw can lead to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1041113

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sox (PTS)buster14.4.2+git20190427-1vulnerable
buster (security)14.4.2+git20190427-1+deb10u3fixed
bullseye (security), bullseye14.4.2+git20190427-2+deb11u2fixed
bookworm14.4.2+git20190427-3.5fixed
trixie, sid14.4.2+git20190427-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soxsourcebuster14.4.2+git20190427-1+deb10u1
soxsourcebullseye14.4.2+git20190427-2+deb11u1
soxsource(unstable)14.4.2+git20190427-3.11041113

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=2212279
https://sourceforge.net/p/sox/bugs/370/
Same fix as for CVE-2022-31650

Search for package or bug name: Reporting problems