CVE-2023-26735

NameCVE-2023-26735
Descriptionblackbox_exporter v0.23.0 was discovered to contain an access control issue in its probe interface. This vulnerability allows attackers to detect intranet ports and services, as well as download resources. NOTE: this is disputed by third parties because authentication can be configured.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prometheus-blackbox-exporter (PTS)buster0.13.0+ds-2vulnerable
bullseye0.18.0+ds-3vulnerable
bookworm0.23.0-4vulnerable
sid, trixie0.24.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prometheus-blackbox-exportersource(unstable)(unfixed)unimportant

Notes

https://github.com/prometheus/blackbox_exporter/issues/1024
https://github.com/prometheus/blackbox_exporter/issues/1024#issuecomment-1526944617
Upstream of the project did disputed the CVE. Upstream position is
that the refererred behaviour is intended functionality.

Search for package or bug name: Reporting problems