CVE-2023-27522

NameCVE-2023-27522
DescriptionHTTP Response Smuggling vulnerability in Apache HTTP Server via mod_proxy_uwsgi. This issue affects Apache HTTP Server: from 2.4.30 through 2.4.55. Special characters in the origin response header can truncate/split the response forwarded to the client.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3401-1, DSA-5376-1
Debian Bugs1032476

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8vulnerable
buster (security)2.4.59-1~deb10u1fixed
bullseye2.4.56-1~deb11u2fixed
bullseye (security)2.4.59-1~deb11u1fixed
bookworm2.4.57-2fixed
bookworm (security)2.4.59-1~deb12u1fixed
trixie, sid2.4.59-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcebuster2.4.38-3+deb10u10DLA-3401-1
apache2sourcebullseye2.4.56-1~deb11u1DSA-5376-1
apache2source(unstable)2.4.56-11032476

Notes

https://www.openwall.com/lists/oss-security/2023/03/07/2
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2023-27522
https://github.com/apache/httpd/commit/0df5879df8f16b4101ea2365672178b4ae899e9e (r1907980)

Search for package or bug name: Reporting problems