CVE-2023-27635

NameCVE-2023-27635
Descriptiondebmany in debian-goodies 0.88.1 allows attackers to execute arbitrary shell commands (because of an eval call) via a crafted .deb file. (The path is shown to the user before execution.)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1031267

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
debian-goodies (PTS)buster0.84vulnerable
bullseye0.87vulnerable
bookworm, sid, trixie0.88.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
debian-goodiessource(unstable)(unfixed)1031267

Notes

[bookworm] - debian-goodies <no-dsa> (Minor issue; user prompted before execution)
[bullseye] - debian-goodies <no-dsa> (Minor issue; user prompted before execution)
[buster] - debian-goodies <no-dsa> (Minor issue; user prompted before execution)

Search for package or bug name: Reporting problems