CVE-2023-2794

NameCVE-2023-2794
DescriptionA flaw was found in ofono, an Open Source Telephony on Linux. A stack overflow bug is triggered within the decode_deliver() function during the SMS decoding. It is assumed that the attack scenario is accessible from a compromised modem, a malicious base station, or just SMS. There is a bound check for this memcpy length in decode_submit(), but it was forgotten in decode_deliver().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1069679

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ofono (PTS)buster1.21-1vulnerable
trixie, bookworm, bullseye1.31-3vulnerable
sid1.31-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ofonosource(unstable)1.31-41069679

Notes

[bookworm] - ofono <no-dsa> (Minor issue)
[bullseye] - ofono <no-dsa> (Minor issue)
[buster] - ofono <postponed> (Minor issue, follow bullseye)
https://bugzilla.redhat.com/show_bug.cgi?id=2255387
https://git.kernel.org/pub/scm/network/ofono/ofono.git/commit/?id=a90421d8e45d63b304dc010baba24633e7869682
https://git.kernel.org/pub/scm/network/ofono/ofono.git/commit/?id=7f2adfa22fbae824f8e2c3ae86a3f51da31ee400
https://git.kernel.org/pub/scm/network/ofono/ofono.git/commit/?id=07f48b23e3877ef7d15a7b0b8b79d32ad0a3607e
https://git.kernel.org/pub/scm/network/ofono/ofono.git/commit/?id=8fa1fdfcb54e1edb588c6a5e2688880b065a39c9

Search for package or bug name: Reporting problems