CVE-2023-28144

NameCVE-2023-28144
DescriptionKDAB Hotspot 1.3.x and 1.4.x through 1.4.1, in a non-default configuration, allows privilege escalation because of race conditions involving symlinks and elevate_perf_privileges.sh chown calls.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1033848

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hotspot (PTS)buster1.1.0+git20190211-1fixed
sid, bookworm, bullseye1.3.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hotspotsourcebuster(not affected)
hotspotsource(unstable)(unfixed)1033848

Notes

[bookworm] - hotspot <no-dsa> (Minor issue)
[bullseye] - hotspot <no-dsa> (Minor issue)
[buster] - hotspot <not-affected> (Vulnerable code not present, introduced in 1.3.0)
https://www.openwall.com/lists/oss-security/2023/03/14/8
Introduced by: https://github.com/KDAB/hotspot/commit/3b4682565f0e53f903f3ad0f3f2c0f236d382efb (v1.3.0)
Opt-In to allow privilege escalation (and disable by default):
https://github.com/KDAB/hotspot/commit/65a246ce9196462081483fd07d97678dcfe36b9c

Search for package or bug name: Reporting problems