CVE-2023-2838

NameCVE-2023-2838
DescriptionOut-of-bounds Read in GitHub repository gpac/gpac prior to 2.2.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5411-1
Debian Bugs1036701

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gpac (PTS)buster0.5.2-426-gc5ad4e4+dfsg5-5vulnerable
bullseye, bullseye (security)1.0.1+dfsg1-4+deb11u3fixed
sid2.2.1+dfsg1-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gpacsourcebuster(unfixed)end-of-life
gpacsourcebullseye1.0.1+dfsg1-4+deb11u2DSA-5411-1
gpacsource(unstable)(unfixed)1036701

Notes

[buster] - gpac <end-of-life> (EOL in buster LTS)
https://huntr.dev/bounties/711e0988-5345-4c01-a2fe-1179604dd07f/
https://github.com/gpac/gpac/commit/c88df2e202efad214c25b4e586f243b2038779ba

Search for package or bug name: Reporting problems