CVE-2023-28410

NameCVE-2023-28410
DescriptionImproper restriction of operations within the bounds of a memory buffer in some Intel(R) i915 Graphics drivers for linux before kernel version 6.2.10 may allow an authenticated user to potentially enable escalation of privilege via local access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)buster4.19.249-2fixed
buster (security)4.19.304-1fixed
bullseye5.10.209-2fixed
bullseye (security)5.10.216-1fixed
bookworm6.1.76-1fixed
bookworm (security)6.1.90-1fixed
trixie6.7.12-1fixed
sid6.8.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster(not affected)
linuxsourcebullseye5.10.113-1
linuxsource(unstable)5.17.3-1

Notes

[buster] - linux <not-affected> (Vulnerable code not present)
https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00886.html
Fixed by: https://git.kernel.org/linus/661412e301e2ca86799aa4f400d1cf0bd38c57c6 (5.19-rc1)
http://blog.pi3.com.pl/?p=931
http://site.pi3.com.pl/adv/CVE-2023-28410_i915.txt

Search for package or bug name: Reporting problems