CVE-2023-28617

NameCVE-2023-28617
Descriptionorg-babel-execute:latex in ob-latex.el in Org Mode through 9.6.1 for GNU Emacs allows attackers to execute arbitrary commands via a file name or directory name that contains shell metacharacters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3416-1, DLA-3616-1
Debian Bugs1033341, 1033342

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
emacs (PTS)buster1:26.1+1-3.2+deb10u2vulnerable
buster (security)1:26.1+1-3.2+deb10u5fixed
bullseye1:27.1+1-3.1+deb11u1vulnerable
bullseye (security)1:27.1+1-3.1+deb11u2vulnerable
bookworm1:28.2+1-15fixed
sid, trixie1:29.3+1-3fixed
org-mode (PTS)buster9.1.14+dfsg-3vulnerable
buster (security)9.1.14+dfsg-3+deb10u2fixed
bullseye9.4.0+dfsg-1+deb11u1fixed
bookworm9.5.2+dfsh-5fixed
sid, trixie9.6.28+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
emacssourcebuster1:26.1+1-3.2+deb10u4DLA-3416-1
emacssource(unstable)1:28.2+1-141033342
org-modesourceexperimental9.6.6+dfsg-1~exp1
org-modesourcebuster9.1.14+dfsg-3+deb10u1DLA-3616-1
org-modesourcebullseye9.4.0+dfsg-1+deb11u1
org-modesource(unstable)9.5.2+dfsh-51033341

Notes

[bullseye] - emacs <no-dsa> (Minor issue)
https://list.orgmode.org/tencent_04CF842704737012CCBCD63CD654DD41CA0A%40qq.com/T/#m6ef8e7d34b25fe17b4cbb655b161edce18c6655e
https://git.savannah.gnu.org/cgit/emacs/org-mode.git/commit/?id=8f8ec2ccf3f5ef8f38d68ec84a7e4739c45db485 (release_9.6.2)
https://git.savannah.gnu.org/cgit/emacs/org-mode.git/commit/?id=a8006ea580ed74f27f974d60b598143b04ad1741 (release_9.6.2)
org-mode/9.5.2+dfsh-5 dropped all lisp files from the produced binary packages
making an empty dependency package only thus considered fixed exceptionally in
that version.

Search for package or bug name: Reporting problems