CVE-2023-28625

NameCVE-2023-28625
Descriptionmod_auth_openidc is an authentication and authorization module for the Apache 2.x HTTP server that implements the OpenID Connect Relying Party functionality. In versions 2.0.0 through 2.4.13.1, when `OIDCStripCookies` is set and a crafted cookie supplied, a NULL pointer dereference would occur, resulting in a segmentation fault. This could be used in a Denial-of-Service attack and thus presents an availability risk. Version 2.4.13.2 contains a patch for this issue. As a workaround, avoid using `OIDCStripCookies`.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3409-1, DSA-5405-1
Debian Bugs1033916

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapache2-mod-auth-openidc (PTS)buster2.3.10.2-1+deb10u1vulnerable
buster (security)2.3.10.2-1+deb10u2fixed
bullseye2.4.9.4-0+deb11u2vulnerable
bullseye (security)2.4.9.4-0+deb11u3fixed
bookworm, sid2.4.12.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapache2-mod-auth-openidcsourcebuster2.3.10.2-1+deb10u2DLA-3409-1
libapache2-mod-auth-openidcsourcebullseye2.4.9.4-0+deb11u3DSA-5405-1
libapache2-mod-auth-openidcsource(unstable)2.4.12.3-21033916

Notes

https://github.com/OpenIDC/mod_auth_openidc/commit/4389182239c0f60cfa4873f9980c826a70047cc4 (v2.4.13.2)
https://github.com/OpenIDC/mod_auth_openidc/security/advisories/GHSA-f5xw-rvfr-24qr

Search for package or bug name: Reporting problems