DescriptionTrustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1035083

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
modsecurity (PTS)buster, buster (security)3.0.3-1+deb10u2fixed
bookworm, sid3.0.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
modsecuritysourcebuster(not affected)
modsecuritysourcebullseye(not affected)


[bullseye] - modsecurity <not-affected> (Vulnerable code not present)
[buster] - modsecurity <not-affected> (Vulnerable code not present)
Introduced by: (v3.0.5)
Fixed by: (v3.0.9)

Search for package or bug name: Reporting problems