CVE-2023-2906

NameCVE-2023-2906
DescriptionDue to a failure in validating the length provided by an attacker-crafted CP2179 packet, Wireshark versions 2.0.0 through 4.0.7 is susceptible to a divide by zero allowing for a denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5559-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u8fixed
bullseye (security), bullseye3.4.10-0+deb11u1vulnerable
bookworm, bookworm (security)4.0.11-1~deb12u1fixed
trixie4.2.2-1fixed
sid4.2.2-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcebuster(not affected)
wiresharksourcebookworm4.0.11-1~deb12u1DSA-5559-1
wiresharksource(unstable)4.0.8-1

Notes

[bullseye] - wireshark <no-dsa> (Minor issue)
[buster] - wireshark <not-affected> (Vulnerable code introduced in 3.0.0)
https://www.wireshark.org/security/wnpa-sec-2023-26.html
https://gitlab.com/wireshark/wireshark/-/issues/19229
Introduced by https://gitlab.com/wireshark/wireshark/-/commit/4ff777d5ce1d9951a1edbf7ffa914a12a00bb2b3 (v2.9.0)

Search for package or bug name: Reporting problems