CVE-2023-29141

NameCVE-2023-29141
DescriptionAn issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6, and 1.39.x before 1.39.3. An auto-block can occur for an untrusted X-Forwarded-For header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3540-1, DSA-5447-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2vulnerable
buster (security)1:1.31.16-1+deb10u7fixed
bullseye1:1.35.13-1~deb11u1fixed
bullseye (security)1:1.35.13-1+deb11u2fixed
bookworm1:1.39.5-1~deb12u1fixed
bookworm (security)1:1.39.7-1~deb12u1fixed
sid, trixie1:1.39.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcebuster1:1.31.16-1+deb10u6DLA-3540-1
mediawikisourcebullseye1:1.35.11-1~deb11u1DSA-5447-1
mediawikisourcebookworm1:1.39.4-1~deb12u1DSA-5447-1
mediawikisource(unstable)1:1.39.4-1

Notes

https://gerrit.wikimedia.org/r/plugins/gitiles/mediawiki/core/+/REL1_39/RELEASE-NOTES-1.39
https://phabricator.wikimedia.org/T285159

Search for package or bug name: Reporting problems