CVE-2023-29479

NameCVE-2023-29479
DescriptionRibose RNP before 0.16.3 may hang when the input is malformed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3400-1, DSA-5392-1
Debian Bugs1034558

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rnp (PTS)bookworm0.16.3-1fixed
sid0.17.0-3fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1vulnerable
buster (security)1:115.9.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.9.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.9.0-1~deb12u1fixed
sid1:115.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rnpsource(unstable)0.16.3-11034558
thunderbirdsourcebuster1:102.10.0-1~deb10u1DLA-3400-1
thunderbirdsourcebullseye1:102.10.0-1~deb11u1DSA-5392-1
thunderbirdsource(unstable)1:102.10.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2023-15/#CVE-2023-29479
https://www.rnpgp.org/blog/2023-04-13-rnp-release-0-16-3/

Search for package or bug name: Reporting problems