CVE-2023-29533

NameCVE-2023-29533
DescriptionA website could have obscured the fullscreen notification by using a combination of <code>window.open</code>, fullscreen requests, <code>window.name</code> assignments, and <code>setInterval</code> calls. This could have led to user confusion and possible spoofing attacks. This vulnerability affects Firefox < 112, Focus for Android < 112, Firefox ESR < 102.10, Firefox for Android < 112, and Thunderbird < 102.10.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3391-1, DLA-3400-1, DSA-5385-1, DSA-5392-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid124.0.1-1fixed
firefox-esr (PTS)buster91.12.0esr-1~deb10u1vulnerable
buster (security)115.9.1esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.9.1esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.9.1esr-1~deb12u1fixed
trixie115.8.0esr-1fixed
sid115.9.1esr-1fixed
thunderbird (PTS)buster1:91.12.0-1~deb10u1vulnerable
buster (security)1:115.9.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.9.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.9.0-1~deb12u1fixed
sid1:115.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)112.0-1
firefox-esrsourcebuster102.10.0esr-1~deb10u1DLA-3391-1
firefox-esrsourcebullseye102.10.0esr-1~deb11u1DSA-5385-1
firefox-esrsource(unstable)102.10.0esr-1
thunderbirdsourcebuster1:102.10.0-1~deb10u1DLA-3400-1
thunderbirdsourcebullseye1:102.10.0-1~deb11u1DSA-5392-1
thunderbirdsource(unstable)1:102.10.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2023-13/#CVE-2023-29533
https://www.mozilla.org/en-US/security/advisories/mfsa2023-14/#CVE-2023-29533
https://www.mozilla.org/en-US/security/advisories/mfsa2023-15/#CVE-2023-29533

Search for package or bug name: Reporting problems