CVE-2023-29579

NameCVE-2023-29579
Descriptionyasm 1.3.0.55.g101bc was discovered to contain a stack overflow via the component yasm/yasm+0x43b466 in vsprintf. Note: This has been disputed by third parties who argue this is a bug and not a security issue because yasm is a standalone program not designed to run untrusted code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1035951

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yasm (PTS)buster1.3.0-2vulnerable
bullseye1.3.0-2.1vulnerable
bookworm1.3.0-4vulnerable
sid, trixie1.3.0-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yasmsource(unstable)(unfixed)1035951

Notes

[bookworm] - yasm <no-dsa> (Minor issue)
[bullseye] - yasm <no-dsa> (Minor issue)
[buster] - yasm <no-dsa> (Minor issue)
https://github.com/yasm/yasm/issues/214

Search for package or bug name: Reporting problems