Descriptionpluto in Libreswan before 4.11 allows a denial of service (responder SPI mishandling and daemon crash) via unauthenticated IKEv1 Aggressive Mode packets. The earliest affected version is 3.28.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1035542

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreswan (PTS)buster, buster (security)3.27-6+deb10u1fixed
bullseye (security), bullseye4.3-1+deb11u3vulnerable
sid, trixie4.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreswansourcebuster(not affected)


[bullseye] - libreswan <no-dsa> (Minor issue; can be fixed via point release)
[buster] - libreswan <not-affected> (The vulnerable code was introduced in version 3.28)
Fix return value for aggr_inI1_outR1: (v4.11)
Fixed by: (v4.11)
Fixed by: (v4.11)
For later followup: (v4.11)
Later followup: (v4.11)

Search for package or bug name: Reporting problems