CVE-2023-30570

NameCVE-2023-30570
Descriptionpluto in Libreswan before 4.11 allows a denial of service (responder SPI mishandling and daemon crash) via unauthenticated IKEv1 Aggressive Mode packets. The earliest affected version is 3.28.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1035542

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreswan (PTS)buster, buster (security)3.27-6+deb10u1fixed
bullseye4.3-1+deb11u4fixed
bullseye (security)4.3-1+deb11u3vulnerable
bookworm4.10-2+deb12u1fixed
sid4.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreswansourcebuster(not affected)
libreswansourcebullseye4.3-1+deb11u4
libreswansourcebookworm4.10-2+deb12u1
libreswansource(unstable)4.11-11035542

Notes

[buster] - libreswan <not-affected> (The vulnerable code was introduced in version 3.28)
https://libreswan.org/security/CVE-2023-30570/CVE-2023-30570.txt
https://github.com/libreswan/libreswan/issues/1039
Fix return value for aggr_inI1_outR1: https://github.com/libreswan/libreswan/commit/0250b5349145f6ac6b9c58e196489f7d048de305 (v4.11)
Fixed by: https://github.com/libreswan/libreswan/commit/a31bf33593e6a15bf1ad1b79ff6bb177a4d39f2c (v4.11)
Fixed by: https://github.com/libreswan/libreswan/commit/f32feb1dd71e4a69636d9d7efbd1ff441acde9d6 (v4.11)
For later followup: https://github.com/libreswan/libreswan/commit/ceaabbd3f7f89712d85ec128c42d75d725879ad2 (v4.11)
Later followup: https://github.com/libreswan/libreswan/commit/b77dc3483996a28703c4ff21225f4f541543f0f1 (v4.11)

Search for package or bug name: Reporting problems