CVE-2023-31102

NameCVE-2023-31102
DescriptionPpmd7.c in 7-Zip before 23.00 allows an integer underflow and invalid read operation via a crafted 7Z archive.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
7zip (PTS)bookworm22.01+dfsg-8vulnerable
sid, trixie23.01+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
7zipsource(unstable)23.01+dfsg-1

Notes

[bookworm] - 7zip <no-dsa> (Minor issue; will be fixed via point release)
https://www.zerodayinitiative.com/advisories/ZDI-23-1165/
https://sourceforge.net/p/sevenzip/discussion/45797/thread/713c8a8269/

Search for package or bug name: Reporting problems