CVE-2023-31437

NameCVE-2023-31437
DescriptionAn issue was discovered in systemd 253. An attacker can modify a sealed log file such that, in some views, not all existing and sealed log messages are displayed. NOTE: the vendor reportedly sent "a reply denying that any of the finding was a security vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemd (PTS)buster241-7~deb10u8vulnerable
buster (security)241-7~deb10u10vulnerable
bullseye247.3-7+deb11u4vulnerable
bookworm252.22-1~deb12u1vulnerable
trixie256-1vulnerable
sid256.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemdsource(unstable)(unfixed)unimportant

Notes

Disputed by upstream
https://github.com/kastel-security/Journald/blob/main/journald-publication.pdf

Search for package or bug name: Reporting problems