CVE-2023-31484

NameCVE-2023-31484
DescriptionCPAN.pm before 2.35 does not verify TLS certificates when downloading distributions over HTTPS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1035109

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)buster5.28.1-6+deb10u1vulnerable
bullseye5.32.1-4+deb11u3vulnerable
bullseye (security)5.32.1-4+deb11u1vulnerable
bookworm5.36.0-7+deb12u1vulnerable
sid, trixie5.38.2-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsourceexperimental5.38.0~rc2-1
perlsource(unstable)5.38.2-21035109

Notes

[bookworm] - perl <no-dsa> (Minor issue)
[bullseye] - perl <no-dsa> (Minor issue)
[buster] - perl <no-dsa> (Minor issue)
https://github.com/andk/cpanpm/pull/175
https://github.com/andk/cpanpm/commit/9c98370287f4e709924aee7c58ef21c85289a7f0 (2.35-TRIAL)

Search for package or bug name: Reporting problems