CVE-2023-31607

NameCVE-2023-31607
DescriptionAn issue in the __libc_malloc component of openlink virtuoso-opensource v7.2.9 allows attackers to cause a Denial of Service (DoS) via crafted SQL statements.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1036467

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
virtuoso-opensource (PTS)buster6.1.6+dfsg2-4vulnerable
bullseye7.2.5.1+dfsg1-0.1vulnerable
bookworm, sid7.2.5.1+dfsg1-0.3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
virtuoso-opensourcesource(unstable)(unfixed)1036467

Notes

[bookworm] - virtuoso-opensource <no-dsa> (Minor issue)
[bullseye] - virtuoso-opensource <no-dsa> (Minor issue)
[buster] - virtuoso-opensource <no-dsa> (Minor issue)
https://github.com/openlink/virtuoso-opensource/issues/1120
https://github.com/openlink/virtuoso-opensource/commit/ea8b2c975c6c96f36e34014d6c71a73761198ebe

Search for package or bug name: Reporting problems