CVE-2023-31608

NameCVE-2023-31608
DescriptionAn issue in the artm_div_int component of openlink virtuoso-opensource v7.2.9 allows attackers to cause a Denial of Service (DoS) via crafted SQL statements.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1036467

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
virtuoso-opensource (PTS)buster6.1.6+dfsg2-4vulnerable
bullseye7.2.5.1+dfsg1-0.1vulnerable
bookworm7.2.5.1+dfsg1-0.3vulnerable
sid7.2.5.1+dfsg1-0.5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
virtuoso-opensourcesource(unstable)(unfixed)1036467

Notes

[bookworm] - virtuoso-opensource <no-dsa> (Minor issue)
[bullseye] - virtuoso-opensource <no-dsa> (Minor issue)
[buster] - virtuoso-opensource <no-dsa> (Minor issue)
https://github.com/openlink/virtuoso-opensource/issues/1123
https://github.com/openlink/virtuoso-opensource/commit/9c5bdeb73b00b5ae88db0be036d429d779126094

Search for package or bug name: Reporting problems