CVE-2023-31614

NameCVE-2023-31614
DescriptionAn issue in the mp_box_deserialize_string function in openlink virtuoso-opensource v7.2.9 allows attackers to cause a Denial of Service (DoS) after running a SELECT statement.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1036467

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
virtuoso-opensource (PTS)buster6.1.6+dfsg2-4vulnerable
bullseye7.2.5.1+dfsg1-0.1vulnerable
bookworm7.2.5.1+dfsg1-0.3vulnerable
sid, trixie7.2.12+dfsg-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
virtuoso-opensourcesourceexperimental7.2.12+dfsg-0.1
virtuoso-opensourcesource(unstable)7.2.12+dfsg-0.21036467

Notes

[bookworm] - virtuoso-opensource <no-dsa> (Minor issue)
[bullseye] - virtuoso-opensource <no-dsa> (Minor issue)
[buster] - virtuoso-opensource <no-dsa> (Minor issue)
https://github.com/openlink/virtuoso-opensource/issues/1117
https://github.com/openlink/virtuoso-opensource/commit/7c488ae70803b208a94bf12fee792195caddbf7d (v7.2.10)

Search for package or bug name: Reporting problems