CVE-2023-32324

NameCVE-2023-32324
DescriptionOpenPrinting CUPS is an open source printing system. In versions 2.4.2 and prior, a heap buffer overflow vulnerability would allow a remote attacker to launch a denial of service (DoS) attack. A buffer overflow vulnerability in the function `format_log_line` could allow remote attackers to cause a DoS on the affected system. Exploitation of the vulnerability can be triggered when the configuration file `cupsd.conf` sets the value of `loglevel `to `DEBUG`. No known patches or workarounds exist at time of publication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3440-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)buster2.2.10-6+deb10u6vulnerable
buster (security)2.2.10-6+deb10u9fixed
bullseye2.3.3op2-3+deb11u6fixed
bullseye (security)2.3.3op2-3+deb11u2vulnerable
bookworm2.4.2-3+deb12u5fixed
sid, trixie2.4.7-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssourcebuster2.2.10-6+deb10u7DLA-3440-1
cupssourcebullseye2.3.3op2-3+deb11u3
cupssourcebookworm2.4.2-3+deb12u1
cupssource(unstable)2.4.2-4

Notes

https://github.com/OpenPrinting/cups/security/advisories/GHSA-cxc6-w2g7-69p7
Fixed by: https://github.com/OpenPrinting/cups/commit/fd8bc2d32589d1fd91fe1c0521be2a7c0462109e

Search for package or bug name: Reporting problems