CVE-2023-33546

NameCVE-2023-33546
DescriptionJanino 3.1.9 and earlier are subject to denial of service (DOS) attacks when using the expression evaluator.guess parameter name method. If the parser runs on user-supplied input, an attacker could supply content that causes the parser to crash due to a stack overflow. NOTE: this is disputed by multiple parties because Janino is not intended for use with untrusted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
janino (PTS)buster2.7.0-2vulnerable
trixie, sid, bookworm, bullseye2.7.0-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
janinosource(unstable)(unfixed)unimportant

Notes

https://github.com/janino-compiler/janino/issues/201
Bug fixed in 3.1.10, but not considered a security issue by upstream

Search for package or bug name: Reporting problems