CVE-2023-33934

NameCVE-2023-33934
DescriptionImproper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.This issue affects Apache Traffic Server: through 9.2.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3595-1, DSA-5549-1
Debian Bugs1043430

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)bullseye (security), bullseye8.1.10+ds-1~deb11u1fixed
bookworm, bookworm (security)9.2.4+ds-0+deb12u1fixed
sid9.2.4+ds-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversourcebuster8.1.7-0+deb10u2DLA-3595-1
trafficserversourcebullseye8.1.9+ds-1~deb11u1DSA-5549-1
trafficserversourcebookworm9.2.3+ds-1+deb12u1DSA-5549-1
trafficserversource(unstable)9.2.2+ds-11043430

Notes

https://lists.apache.org/thread/jsl6dfdgs1mjjo1mbtyflyjr7xftswhc

Search for package or bug name: Reporting problems