DescriptionA vulnerability in for Poppler prior to 23.06.0 allows a remote attacker to cause a Denial of Service (DoS) (crash) via a crafted PDF file in OutlineItem::open.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1042811

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u2fixed
bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
sid, trixie, bookworm22.12.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcebuster(not affected)
popplersourcebullseye(not affected)


[bookworm] - poppler <no-dsa> (Minor issue)
[bullseye] - poppler <not-affected> (Vulnerable code introduced later)
[buster] - poppler <not-affected> (Vulnerable code introduced later)
Introduced by: (poppler-21.08.0)
Fixed by: (poppler-23.06.0)

Search for package or bug name: Reporting problems