CVE-2023-36054

NameCVE-2023-36054
Descriptionlib/kadm5/kadm_rpc_xdr.c in MIT Kerberos 5 (aka krb5) before 1.20.2 and 1.21.x before 1.21.1 frees an uninitialized pointer. A remote authenticated user can trigger a kadmind crash. This occurs because _xdr_kadm5_principal_ent_rec does not validate the relationship between n_key_data and the key_data array count.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3626-1
Debian Bugs1043431

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)buster1.17-3+deb10u4vulnerable
buster (security)1.17-3+deb10u6fixed
bullseye1.18.3-6+deb11u4fixed
bullseye (security)1.18.3-6+deb11u3vulnerable
bookworm1.20.1-2+deb12u1fixed
trixie1.20.1-5fixed
sid1.20.1-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcebuster1.17-3+deb10u6DLA-3626-1
krb5sourcebullseye1.18.3-6+deb11u4
krb5sourcebookworm1.20.1-2+deb12u1
krb5source(unstable)1.20.1-31043431

Notes

https://github.com/krb5/krb5/commit/ef08b09c9459551aabbe7924fb176f1583053cdd

Search for package or bug name: Reporting problems