CVE-2023-3637

NameCVE-2023-3637
DescriptionAn uncontrolled resource consumption flaw was found in openstack-neutron. This flaw allows a remote authenticated user to query a list of security groups for an invalid project. This issue creates resources that are unconstrained by the user's quota. If a malicious user were to submit a significant number of requests, this could lead to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
neutron (PTS)buster, buster (security)2:13.0.7+git.2021.09.27.bace3d1890-0+deb10u1fixed
bullseye, bullseye (security)2:17.2.1-0+deb11u1fixed
bookworm2:21.0.0-7fixed
sid, trixie2:23.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
neutronsource(unstable)(not affected)

Notes

- neutron <not-affected> (Fix for CVE-2022-3277 not applied)
https://bugzilla.redhat.com/show_bug.cgi?id=2222270

Search for package or bug name: Reporting problems