CVE-2023-37418

NameCVE-2023-37418
DescriptionMultiple out-of-bounds write vulnerabilities exist in the VCD parse_valuechange portdump functionality of GTKWave 3.3.115. A specially crafted .vcd file can lead to arbitrary code execution. A victim would need to open a malicious file to trigger these vulnerabilities.This vulnerability concerns the out-of-bounds write when triggered via the vcd2vzt conversion utility.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3785-1, DSA-5653-1
Debian Bugs1060407

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gtkwave (PTS)buster3.3.98-1vulnerable
buster (security)3.3.98+really3.3.118-0+deb10u1fixed
bullseye3.3.104-2vulnerable
bullseye (security)3.3.104+really3.3.118-0+deb11u1fixed
bookworm3.3.114-2vulnerable
bookworm (security)3.3.118-0.1~deb12u1fixed
sid, trixie3.3.118-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gtkwavesourcebuster3.3.98+really3.3.118-0+deb10u1DLA-3785-1
gtkwavesourcebullseye3.3.104+really3.3.118-0+deb11u1DSA-5653-1
gtkwavesourcebookworm3.3.118-0.1~deb12u1DSA-5653-1
gtkwavesource(unstable)3.3.118-0.11060407

Notes

https://talosintelligence.com/vulnerability_reports/TALOS-2023-1804

Search for package or bug name: Reporting problems