CVE-2023-38060

NameCVE-2023-38060
DescriptionImproper Input Validation vulnerability in the ContentType parameter for attachments on TicketCreate or TicketUpdate operations of the OTRS Generic Interface modules allows any authenticated attacker to to perform an host header injection for the ContentType header of the attachment.  This issue affects OTRS: from 7.0.X before 7.0.45, from 8.0.X before 8.0.35; ((OTRS)) Community Edition: from 6.0.1 through 6.0.34.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3551-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
otrs2 (PTS)bullseye/non-free6.0.32-6vulnerable
znuny (PTS)bookworm/non-free6.5.1-1vulnerable
trixie/non-free6.5.8-1fixed
sid/non-free6.5.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
otrs2sourcebuster6.0.16-2+deb10u1DLA-3551-1
otrs2source(unstable)(unfixed)
znunysource(unstable)6.5.3-1

Notes

[bookworm] - znuny <no-dsa> (Minor issue)
[bullseye] - otrs2 <no-dsa> (Minor issue)
https://github.com/znuny/Znuny/commit/355800e68c1560c1d098ec0953ee9940d2d1f836 (rel-6_5_3)

Search for package or bug name: Reporting problems