CVE-2023-38406

NameCVE-2023-38406
Descriptionbgpd/bgp_flowspec.c in FRRouting (FRR) before 8.4.3 mishandles an nlri length of zero, aka a "flowspec overflow."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3797-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
frr (PTS)buster6.0.2-2+deb10u1vulnerable
buster (security)7.5.1-1.1+deb10u2fixed
bullseye (security), bullseye7.5.1-1.1+deb11u2vulnerable
bookworm, bookworm (security)8.4.4-1.1~deb12u1fixed
sid, trixie10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
frrsourcebuster7.5.1-1.1+deb10u2DLA-3797-1
frrsourcebookworm8.4.4-1.1~deb12u1
frrsource(unstable)8.4.4-1

Notes

https://github.com/FRRouting/frr/pull/12884
https://github.com/FRRouting/frr/pull/12892 (backport for stable/8.4)
https://github.com/FRRouting/frr/commit/8a4e6637fc0621e90daa4decb4ee887a0af8ee24 (frr-8.4.3)

Search for package or bug name: Reporting problems