CVE-2023-38709

NameCVE-2023-38709
DescriptionFaulty input validation in the core of Apache allows malicious or exploitable backend/content generators to split HTTP responses. This issue affects Apache HTTP Server: through 2.4.58.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3818-1, DSA-5662-1
Debian Bugs1068412

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)buster2.4.38-3+deb10u8vulnerable
buster (security)2.4.59-1~deb10u1fixed
bullseye2.4.56-1~deb11u2vulnerable
bullseye (security)2.4.59-1~deb11u1fixed
bookworm2.4.57-2vulnerable
bookworm (security)2.4.59-1~deb12u1fixed
sid, trixie2.4.59-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcebuster2.4.59-1~deb10u1DLA-3818-1
apache2sourcebullseye2.4.59-1~deb11u1DSA-5662-1
apache2sourcebookworm2.4.59-1~deb12u1DSA-5662-1
apache2source(unstable)2.4.59-11068412

Notes

https://www.openwall.com/lists/oss-security/2024/04/04/3
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2023-38709
https://github.com/apache/httpd/commit/ac20389f3c816d990aba21720f1492b69ac5cb44

Search for package or bug name: Reporting problems