CVE-2023-38802

NameCVE-2023-38802
DescriptionFRRouting FRR 7.5.1 through 9.0 and Pica8 PICOS 4.3.3.2 allow a remote attacker to cause a denial of service via a crafted BGP update with a corrupted attribute 23 (Tunnel Encapsulation).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3573-1, DSA-5495-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
frr (PTS)buster6.0.2-2+deb10u1vulnerable
buster (security)7.5.1-1.1+deb10u1fixed
bullseye (security), bullseye7.5.1-1.1+deb11u2fixed
bookworm, bookworm (security)8.4.4-1.1~deb12u1fixed
sid9.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
frrsourcebuster7.5.1-1.1+deb10u1DLA-3573-1
frrsourcebullseye7.5.1-1.1+deb11u2DSA-5495-1
frrsourcebookworm8.4.4-1.1~deb12u1DSA-5495-1
frrsource(unstable)8.4.4-1.1

Notes

https://blog.benjojo.co.uk/post/bgp-path-attributes-grave-error-handling
https://github.com/FRRouting/frr/pull/14290
https://github.com/FRRouting/frr/commit/bcb6b58d9530173df41d3a3cbc4c600ee0b4b186
Backport for stable/8.4: https://github.com/FRRouting/frr/pull/14295
https://github.com/FRRouting/frr/commit/46817adab03802355c3cce7b753c7a735bdcc5ae

Search for package or bug name: Reporting problems