CVE-2023-3966

NameCVE-2023-3966
DescriptionA flaw was found in Open vSwitch where multiple versions are vulnerable to crafted Geneve packets, which may result in a denial of service and invalid memory accesses. Triggering this issue requires that hardware offloading via the netlink path is enabled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1063492

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvswitch (PTS)buster2.10.7+ds1-0+deb10u1fixed
buster (security)2.10.7+ds1-0+deb10u5fixed
bullseye (security), bullseye2.15.0+ds1-2+deb11u4vulnerable
bookworm3.1.0-2vulnerable
trixie3.3.0~git20240118.e802fe7-3vulnerable
sid3.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvswitchsourcebuster(not affected)
openvswitchsource(unstable)3.3.0-11063492

Notes

[buster] - openvswitch <not-affected> (Vulnerable feature introduced later)
https://www.openwall.com/lists/oss-security/2024/02/08/3
Introduced by: https://github.com/openvswitch/ovs/commit/a468645c6d330943dbe0c8d466e05b9af2d7df0c (v2.11.0)
Fixed by: https://github.com/openvswitch/ovs/commit/2cfbcd5247ed0fd941c1ebb9f4adb952b67fe13a (v3.2.2)
Fixed by: https://github.com/openvswitch/ovs/commit/91e621bd5abab19954bec09c7d27c59acdf607b1 (v3.1.4)
Fixed by: https://github.com/openvswitch/ovs/commit/935cd1d574c6f432a451df8941374ffb36d767d9 (v3.0.6)
Fixed by: https://github.com/openvswitch/ovs/commit/b8657dada9641fbd2bd3a3f882e0862448d60910 (v2.17.9)
https://mail.openvswitch.org/pipermail/ovs-dev/2024-February/411702.html

Search for package or bug name: Reporting problems