CVE-2023-40032

NameCVE-2023-40032
Descriptionlibvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vips (PTS)buster8.7.4-1+deb10u1fixed
bullseye8.10.5-2fixed
bookworm8.14.1-3+deb12u1fixed
trixie, sid8.15.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vipssourcebuster(not affected)
vipssourcebullseye(not affected)
vipssourcebookworm8.14.1-3+deb12u1
vipssource(unstable)8.14.4-1

Notes

[bullseye] - vips <not-affected> (Vulnerable code not present)
[buster] - vips <not-affected> (Vulnerable code not present)
https://github.com/libvips/libvips/pull/3604
Introduced by: https://github.com/libvips/libvips/commit/b2527da53143a38bca96f4a3371ccd0856c0268b (v8.12.0-rc1)
Fixed by: https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b (v8.14.4)

Search for package or bug name: Reporting problems