Descriptionlibvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vips (PTS)bullseye8.10.5-2fixed
sid, trixie8.15.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vipssourcebuster(not affected)
vipssourcebullseye(not affected)


[bullseye] - vips <not-affected> (Vulnerable code not present)
[buster] - vips <not-affected> (Vulnerable code not present)
Introduced by: (v8.12.0-rc1)
Fixed by: (v8.14.4)

Search for package or bug name: Reporting problems