CVE-2023-41056

NameCVE-2023-41056
DescriptionRedis is an in-memory database that persists on disk. Redis incorrectly handles resizing of memory buffers which can result in integer overflow that leads to heap overflow and potential remote code execution. This issue has been patched in version 7.0.15 and 7.2.4.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5610-1
Debian Bugs1060316

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)buster5:5.0.14-1+deb10u2fixed
buster (security)5:5.0.14-1+deb10u5fixed
bullseye (security), bullseye5:6.0.16-1+deb11u2fixed
bookworm, bookworm (security)5:7.0.15-1~deb12u1fixed
trixie, sid5:7.0.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissourcebuster(not affected)
redissourcebullseye(not affected)
redissourcebookworm5:7.0.15-1~deb12u1DSA-5610-1
redissource(unstable)5:7.0.15-11060316

Notes

[bullseye] - redis <not-affected> (Vulnerable code not present)
[buster] - redis <not-affected> (Vulnerable code not present)
Introduced with changes from: https://github.com/redis/redis/pull/11766 (which landed
in 7.2, but which also got backported to the 7.0. branch)
https://github.com/redis/redis/commit/e351099e1119fb89496be578f5232c61ce300224 (7.0.15)

Search for package or bug name: Reporting problems