CVE-2023-41164

NameCVE-2023-41164
DescriptionIn Django 3.2 before 3.2.21, 4.1 before 4.1.11, and 4.2 before 4.2.5, django.utils.encoding.uri_to_iri() is subject to a potential DoS (denial of service) attack via certain inputs with a very large number of Unicode characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3558-1
Debian Bugs1051226

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)buster1:1.11.29-1~deb10u1vulnerable
buster (security)1:1.11.29-1+deb10u11fixed
bullseye (security), bullseye2:2.2.28-1~deb11u2vulnerable
bookworm, bookworm (security)3:3.2.19-1+deb12u1vulnerable
sid, trixie3:4.2.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcebuster1:1.11.29-1+deb10u10DLA-3558-1
python-djangosource(unstable)3:3.2.21-11051226

Notes

[bookworm] - python-django <postponed> (Minor issue, fix along in future update)
[bullseye] - python-django <postponed> (Minor issue, fix along in future update)
https://www.openwall.com/lists/oss-security/2023/09/04/1
https://www.djangoproject.com/weblog/2023/sep/04/security-releases/
https://github.com/django/django/commit/3f41d6d62929dfe53eda8109b3b836f26645bdce (main)
https://github.com/django/django/commit/9c51b4dcfa0cefcb48231f4d71cafa80821f87b9 (4.2.5)
https://github.com/django/django/commit/6f030b1149bd8fa4ba90452e77cb3edc095ce54e (3.2.21)

Search for package or bug name: Reporting problems