CVE-2023-42282

NameCVE-2023-42282
DescriptionThe ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally routable via isPublic.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1063535

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-ip (PTS)buster1.1.5-3vulnerable
bullseye1.1.5-5vulnerable
sid, trixie, bookworm2.0.0+~1.1.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-ipsource(unstable)(unfixed)1063535

Notes

[bookworm] - node-ip <no-dsa> (Minor issue)
[bullseye] - node-ip <no-dsa> (Minor issue)
[buster] - node-ip <no-dsa> (Minor issue)
https://huntr.com/bounties/bfc3b23f-ddc0-4ee7-afab-223b07115ed3/
https://cosmosofcyberspace.github.io/npm_ip_cve/npm_ip_cve.html
https://github.com/indutny/node-ip/issues/136

Search for package or bug name: Reporting problems