CVE-2023-4232

NameCVE-2023-4232
DescriptionA flaw was found in ofono, an Open Source Telephony on Linux. A stack overflow bug is triggered within the decode_status_report() function during the SMS decoding. It is assumed that the attack scenario is accessible from a compromised modem, a malicious base station, or just SMS. There is a bound check for this memcpy length in decode_submit(), but it was forgotten in decode_status_report().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070371

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ofono (PTS)buster1.21-1vulnerable
sid, trixie, bookworm, bullseye1.31-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ofonosource(unstable)(unfixed)1070371

Notes

[bookworm] - ofono <no-dsa> (Minor issue)
[bullseye] - ofono <no-dsa> (Minor issue)
[buster] - ofono <postponed> (Minor issue, follow bullseye)
https://bugzilla.redhat.com/show_bug.cgi?id=2255394

Search for package or bug name: Reporting problems