CVE-2023-42465

NameCVE-2023-42465
DescriptionSudo before 1.9.15 might allow row hammer attacks (for authentication bypass or privilege escalation) because application logic sometimes is based on not equaling an error value (instead of equaling a success value), and because the values do not resist flips of a single bit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)bullseye (security), bullseye1.9.5p2-3+deb11u1vulnerable
bookworm1.9.13p3-1+deb12u1vulnerable
sid, trixie1.9.15p5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.9.15p2-2

Notes

[bookworm] - sudo <no-dsa> (Minor issue)
[bullseye] - sudo <no-dsa> (Minor issue)
[buster] - sudo <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2023/12/21/9
https://github.com/sudo-project/sudo/commit/7873f8334c8d31031f8cfa83bd97ac6029309e4f (SUDO_1_9_15p1)
it is more an hardening against hardware bug (rowhammer) than a security fix per se
part of the code in the fix commit are not built because debian use PAM: plugins/sudoers/auth/sudo_auth.[ch]
plugins/sudoers/lookup.c part was added in version 1.9.15
plugins/sudoers/match.c, part was added in 1.8.21

Search for package or bug name: Reporting problems