CVE-2023-42822

NameCVE-2023-42822
Descriptionxrdp is an open source remote desktop protocol server. Access to the font glyphs in xrdp_painter.c is not bounds-checked . Since some of this data is controllable by the user, this can result in an out-of-bounds read within the xrdp executable. The vulnerability allows an out-of-bounds read within a potentially privileged process. On non-Debian platforms, xrdp tends to run as root. Potentially an out-of-bounds write can follow the out-of-bounds read. There is no denial-of-service impact, providing xrdp is running in forking mode. This issue has been addressed in release 0.9.23.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1053284

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xrdp (PTS)buster0.9.9-1+deb10u1vulnerable
buster (security)0.9.9-1+deb10u3vulnerable
bullseye (security), bullseye0.9.21.1-1~deb11u1vulnerable
bookworm0.9.21.1-1vulnerable
trixie0.9.24-3fixed
sid0.9.24-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xrdpsourceexperimental0.9.24-1
xrdpsource(unstable)0.9.24-21053284

Notes

[bookworm] - xrdp <no-dsa> (Minor issue)
[bullseye] - xrdp <no-dsa> (Minor issue)
[buster] - xrdp <no-dsa> (Minor issue)
https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-2hjx-rm4f-r9hw
https://github.com/neutrinolabs/xrdp/commit/73acbe1f7957c65122b00de4d6f57a8d0d257c40

Search for package or bug name: Reporting problems