CVE-2023-43040

NameCVE-2023-43040
DescriptionIBM Spectrum Fusion HCI 2.5.2 through 2.7.2 could allow an attacker to perform unauthorized actions in RGW for Ceph due to improper bucket access. IBM X-Force ID: 266807.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3629-1
Debian Bugs1053690

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ceph (PTS)buster12.2.11+dfsg1-2.1vulnerable
buster (security)12.2.11+dfsg1-2.1+deb10u1fixed
bullseye14.2.21-1vulnerable
bookworm16.2.11+ds-2vulnerable
trixie18.2.1+ds-9fixed
sid18.2.3+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cephsourcebuster12.2.11+dfsg1-2.1+deb10u1DLA-3629-1
cephsource(unstable)16.2.11+ds-51053690

Notes

[bookworm] - ceph <no-dsa> (Minor issue)
[bullseye] - ceph <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2023/09/26/10
https://tracker.ceph.com/issues/63004
https://github.com/ceph/ceph/pull/53714
Fixed by: https://github.com/ceph/ceph/commit/100d81aa060f061271499f1fa28dbdc06de443fd (main)

Search for package or bug name: Reporting problems