CVE-2023-43615

NameCVE-2023-43615
DescriptionMbed TLS 2.x before 2.28.5 and 3.x before 3.5.0 has a Buffer Overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)buster2.16.0-1vulnerable
buster (security)2.16.9-0~deb10u1vulnerable
bullseye2.16.9-0.1vulnerable
bookworm2.28.3-1vulnerable
trixie2.28.7-1vulnerable
sid2.28.8-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)(unfixed)unimportant

Notes

https://mbed-tls.readthedocs.io/en/latest/security-advisories/mbedtls-security-advisory-2023-10-1/
Vulnerability not present in default build and only present if compile-time
configuration enables vulnerable cipher suites. Debian does not enable
MBEDTLS_CIPHER_NULL_CIPHER and MBEDTLS_ARC4_C.

Search for package or bug name: Reporting problems