CVE-2023-43796

NameCVE-2023-43796
DescriptionSynapse is an open-source Matrix homeserver Prior to versions 1.95.1 and 1.96.0rc1, cached device information of remote users can be queried from Synapse. This can be used to enumerate the remote users known to a homeserver. System administrators are encouraged to upgrade to Synapse 1.95.1 or 1.96.0rc1 to receive a patch. As a workaround, the `federation_domain_whitelist` can be used to limit federation traffic with a homeserver.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055255

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
matrix-synapse (PTS)trixie1.95.1-1fixed
sid1.97.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
matrix-synapsesource(unstable)1.95.1-11055255

Notes

https://github.com/matrix-org/synapse/security/advisories/GHSA-mp92-3jfm-3575
https://github.com/matrix-org/synapse/commit/daec55e1fe120c564240c5386e77941372bf458f (v1.95.1)

Search for package or bug name: Reporting problems