CVE-2023-44488

NameCVE-2023-44488
DescriptionVP9 in libvpx before 1.13.1 mishandles widths, leading to a crash related to encoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3598-1, DSA-5518-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvpx (PTS)buster1.7.0-3+deb10u1vulnerable
buster (security)1.7.0-3+deb10u2fixed
bullseye, bullseye (security)1.9.0-1+deb11u2fixed
bookworm, bookworm (security)1.12.0-1+deb12u2fixed
trixie, sid1.13.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvpxsourcebuster1.7.0-3+deb10u2DLA-3598-1
libvpxsourcebullseye1.9.0-1+deb11u2DSA-5518-1
libvpxsourcebookworm1.12.0-1+deb12u2DSA-5518-1
libvpxsource(unstable)1.12.0-1.2

Notes

https://github.com/webmproject/libvpx/commit/263682c9a29395055f3b3afe2d97be1828a6223f (main)
https://github.com/webmproject/libvpx/commit/df9fd9d5b7325060b2b921558a1eb20ca7880937 (v1.13.1)
http://www.openwall.com/lists/oss-security/2023/09/30/4

Search for package or bug name: Reporting problems